Skedulo web app performance degradation
Incident Report for Skedulo
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 14:02 AEST
Investigating
We are currently investigating an issue related to performance within the Skedulo web app. Some users may experience some intermittent latency/slowness.
Posted Jan 15, 2025 - 09:10 AEST
This incident affected: Skedulo Web App.