Salesforce Slowness
Incident Report for Skedulo
Resolved
Salesforce API performance appears to have recovered
Posted over 2 years ago. Jun 24, 2016 - 23:37 AEST
Monitoring
Salesforce is currently experiencing performance degradation across several regions. This may affect the performance and stability of your Skedulo account.

Please refer to the following link for real time information http://trust.salesforce.com/
Posted over 2 years ago. Jun 24, 2016 - 16:49 AEST