The Skedulo Mobile Application was impacted by an internal system issue, causing degraded service for a short period. We have restored service and will continue to investigate the cause to prevent a reoccurrence. All functionality is now restored.
Resolved
The Skedulo Mobile Application was impacted by an internal system issue, causing degraded service for a short period. We have restored service and will continue to investigate the cause to prevent a reoccurrence. All functionality is now restored.
Investigating
Our team has identified an issue within the Skedulo Plus mobile app. Some users may experience "Internal server error" when trying to access the app. We are working on it with the highest priority.