Unplanned Outage
Incident Report for Skedulo
Resolved
The issue is now resolved.
Outage occurred from 10:13 to 10:23am AEST
Posted 11 months ago. May 24, 2018 - 10:56 AEST
Monitoring
Skedulo classic is currently down, we're investing now as our highest priority.
Posted 11 months ago. May 24, 2018 - 10:55 AEST
This incident affected: Skedulo Classic.