This incident has been resolved.
Resolved
Monitoring
A fix has been implemented and we are monitoring the results.
Investigating
Some users may not be able to use the Skedulo Plus app. We are investigating and will post an update shortly.