Some Jobs Not Displaying in Skedulo Plus

Incident Report for Skedulo

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 09:33 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2025 - 16:46 AEST

Update

We are working on deploying a fix and it should be in production within the next few hours. This will be a backend change and will not require any action from customers.
Posted Aug 05, 2025 - 14:12 AEST

Identified

The issue has been identified and affects Android devices and jobs linked to recurring schedules.

This only impacts customers on the Skedulo on Salesforce product.

We are currently working on a fix.
Posted Aug 05, 2025 - 12:29 AEST

Investigating

Some jobs may not be displaying in Skedulo Plus. We are currently investigating this issue.
Posted Aug 05, 2025 - 10:30 AEST
This incident affected: Skedulo Mobile App.