Messaging Not Displaying in Skedulo Plus

Incident Report for Skedulo

Resolved

The incident has been resolved in the latest Skedulo Plus Android patch (v3.18.1), now available on the Play Store. Please update the app on your device to this version.
Posted Aug 07, 2025 - 16:58 AEST

Identified

This issue has been identified and we are working on creating a patch to resolve it. This will be released once approved by the app store.
Posted Aug 06, 2025 - 12:32 AEST

Investigating

Messaging is not loading for users accessing the Skedulo Plus application with Android devices. We are currently investigating this issue.
Posted Aug 06, 2025 - 05:50 AEST
This incident affected: Skedulo Mobile App.