The Skedulo Mobile Application was impacted by an internal system issue, causing degraded service for a short period. We have restored service and will continue to investigate the cause to prevent a reoccurrence. All functionality is now restored.
Resolved
The Skedulo Mobile Application was impacted by an internal system issue, causing degraded service for a short period. We have restored service and will continue to investigate the cause to prevent a reoccurrence. All functionality is now restored.
Investigating
Some users may experience a forced log-out when trying to access the app. Our team is actively investigating this issue as a top priority, and we will provide updates as soon as possible