System Outage
Incident Report for Skedulo
Resolved
This issue is now resolved, all systems are operational.
Posted about 1 year ago. Apr 18, 2018 - 16:46 AEST
Investigating
Our new web app and backend api are currently down, we're investing now as our highest priority.
Posted about 1 year ago. Apr 18, 2018 - 16:35 AEST