Resolved
This incident has been resolved.
Monitoring
Service has been restored
Identified
Our team has identified an issue within the Skedulo Plus mobile app. Some users may experience performance degradation and/or errors related to syncing. Please note this is only for Skedulo Plus, the v2 version of our mobile app is not impacted