Skedulo Plus outage
Resolved·Partial outage

This incident has been resolved.

Fri, Apr 11, 2025, 03:55 AM
(6 months ago)
·
Affected components
Skedulo Mobile App
Updates

Resolved

This incident has been resolved.

Fri, Apr 11, 2025, 03:55 AM

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Apr 10, 2025, 05:25 AM(22 hours earlier)

Investigating

Some users may not be able to use the Skedulo Plus app. We are investigating and will post an update shortly.

Thu, Apr 10, 2025, 04:55 AM(30 minutes earlier)
Powered by