Identified
The team has implemented some changes aimed at improving the app’s performance. Further work is still in progress, and updates will be shared as they become available.
Investigating
We are currently investigating a reported issue affecting multiple customers who is experiencing issues on Skedulo WebApp. Our team is actively working to identify the root cause and will provide updates as soon as we have more information.