Web app loading and performance issues
Resolved·Degraded performance

The incident affecting web app loading and performance has been resolved. All systems are now operating normally.

Thank you for your understanding and patience. If you experience any further issues, please don’t hesitate to reach out by logging a ticket in https://support.skedulo.com

Tue, Nov 4, 2025, 10:07 PM
(2 days ago)
·
Affected components
Updates

Resolved

The incident affecting web app loading and performance has been resolved. All systems are now operating normally.

Thank you for your understanding and patience. If you experience any further issues, please don’t hesitate to reach out by logging a ticket in https://support.skedulo.com

Tue, Nov 4, 2025, 10:07 PM

Monitoring

A fix has been applied for the incident. We are currently monitoring the system to ensure full stability and confirm the issue is resolved.

We appreciate your patience as we verify the resolution.

Mon, Nov 3, 2025, 11:42 PM(22 hours earlier)

Investigating

We are currently investigating a reported issue affecting Salesforce and Pulse customers in the web app. Our team is actively working to identify the root cause and will provide updates as soon as we have more information.

Mon, Nov 3, 2025, 11:07 PM(35 minutes earlier)
Powered by