iOS 14.2 issue prevents Skedulo opening when installed via a mobile device management (MDM) solution
Incident Report for Skedulo
Resolved
Apple have released iOS 14.4 which includes a resolution to this issue
Posted Jan 27, 2021 - 12:38 AEST
Update
We are continuing to monitor for any further issues.
Posted Jan 13, 2021 - 16:45 AEST
Monitoring
A known issue in iOS version 14.2 and above is currently preventing multiple applications, including Skedulo, from opening on certain Apple devices, if they are installed on the device from an MDM solution.

Skedulo are aware of the issue and regret the inconvenience it is causing customers who deploy our application via MDM.

Please note that Skedulo does work on the same devices, when downloaded and installed directly from the App Store. The issue only arises in conjunction with an MDM.

As a release date for a fix from Apple is unknown at this stage, Skedulo is testing the proposed workaround from the Xamarin forums to see if this is applicable to our application. This testing is expected to take several weeks.

In the meantime, we recommend customers who use MDM solutions do not upgrade to iOS 14.2 or above, or alternatively to install our application directly from the App Store.

We will update this notice as more information becomes available from Apple.

References:
https://developer.apple.com/forums/thread/666399
https://github.com/xamarin/xamarin-macios/issues/10086#
Posted Jan 13, 2021 - 16:44 AEST
This incident affected: Skedulo Mobile App.